Purchase & Top-up transactions charged twice
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 20:56 HKT
Identified
We are aware of a processing issue with one of our payment partners. As a result, some crypto purchase transactions and Crypto.com Visa card top-ups for the period 2021-10-06 19:00:00 – 2021-10-07 18:59:59 UTC were charged twice to customer cards. Please rest assured we are working to resolve this within the next 24 hours by reversing the doubled charges ensuring that impacted cardholders will experience no consequences because of currency exchange rate fluctuations.
Posted Oct 11, 2021 - 16:28 HKT