ATOM Deposits Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 12:51 HKT
Investigating
ATOM deposits are delayed. We are currently investigating this issue.
Posted Apr 10, 2021 - 17:16 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).