Crypto Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 15, 2020 - 03:31 HKT
Investigating
Crypto deposits/withdrawals are delayed. We are currently investigating this issue.
Posted Aug 14, 2020 - 20:15 HKT
This incident affected: Crypto.com Exchange (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).