Issue with Card Payment Services for US users

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 15:03 HKT

Update

We are continuing to investigate this issue.
Posted Jul 31, 2026 - 13:45 HKT

Investigating

We are currently experiencing an issue with our US payment provider. As a result, US users may experience intermittent delays or errors when topping up cards, viewing deposit methods, setting up bank accounts, or transferring funds.

Please be assured that your funds and transactions are completely safe. We are actively investigating the issue and will provide updates as soon as we have more information.
Posted Jul 31, 2026 - 13:32 HKT