XLM Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 20, 2020 - 12:13 HKT
Investigating
XLM withdrawals are delayed. We are currently investigating this issue.
Posted Sep 19, 2020 - 15:43 HKT
This incident affected: Crypto.com Exchange (Withdrawals) and Crypto.com App Wallet (Withdrawals).