EGLD Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 04, 2022 - 03:02 HKT
Monitoring
🚨 Crypto.com is supporting the Elrond (EGLD) network upgrade 🚨

🗓️ Scheduled at epoch 795 or approximately 3 Oct 2022 at 15:15 UTC
❗ Exact date and time is subject to change due to variable block times

ℹ️ Elrond network deposits and withdrawals will be temporarily suspended in the Crypto.com App and Exchange on 3 Oct 2022, 14:00 UTC
✅ Trading on Elrond will not be affected

Details 👉 https://crypto.com/product-news/crypto-com-app-and-exchange-to-support-elrond-egld-network-upgrade
Posted Oct 03, 2022 - 22:41 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).