Intermittent Issues with US/Canada Fiat Wallet, Cards, Limit orders and UpDown Options
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 19:38 HKT
Investigating
We are experiencing some intermittent system issues related to the US and Canada fiat wallets, as well as Crypto.com card operations across all regions. UpDown options are also intermittently impacted.

Users will experience error messages when interacting with these features.

You may see your Crypto.com Visa card balance temporarily incorrect, please be assured your balance is not lost.

Our teams are looking into this issue with our vendors with the highest urgency. We appreciate your patience and will keep you posted once there is an update.
Posted Mar 21, 2024 - 17:07 HKT