Intermittent Issues with US/Canada Fiat Wallet, Cards and UpDown Options
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 07, 2023 - 22:58 HKT
Identified
We are experiencing some intermittent system issues related to the US and Canada fiat wallets, as well as Crypto.com card operations across all regions. UpDown options are also intermittently impacted.

Users will experience error messages when interacting with these features.

Our teams are looking into this issue with our vendors with the highest urgency, we appreciated your patience and apologize for the inconvenience.
Posted Sep 07, 2023 - 21:48 HKT