CRONOS NETWORK Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted May 03, 2022 - 12:31 HKT
Monitoring
CRONOS NETWORK withdrawals are delayed. We are currently monitoring this issue.
Posted Apr 30, 2022 - 22:58 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).