Unable to process account closure requests

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 23:54 HKT

Investigating

We are currently experiencing intermittent issues with account closure requests in the Main App.

Our technical teams are investigating the root cause and working to resolve this with high priority.

We appreciate your patience and will provide updates as soon as they become available.
Posted Mar 20, 2025 - 23:09 HKT