Some stocks/ETF orders not currently filling to completion

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 01:51 HKT

Investigating

We are investigating an issue related to incomplete stocks/ETF orders. Rest assured that your funds remain safe and secure during this process and no action is needed on your part.
Posted Sep 12, 2025 - 01:38 HKT