UCH Trading Temporarily Paused
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 16:45 HKT
Identified
UCH trading is temporarily paused due to low liquidity level. We are closely monitoring the situation and will keep the community updated
Posted Sep 17, 2021 - 11:16 HKT