App Slowness and Exchange Login Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 01:33 HKT
Investigating
We are investigating an issue with app slowness and Exchange logins -- we appreciate your patience while we look into this with urgency.
Posted Jan 08, 2021 - 00:29 HKT
This incident affected: Crypto.com App (Main Page) and Crypto.com Exchange (Web Server).