NFT Login Issue
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jul 06, 2022 - 19:00 HKT
Investigating
We are aware of users experiencing the NFT logins issue.
Our team is working on urgently resolving this. Thank you for your patience.
Posted Jul 06, 2022 - 16:38 HKT
This incident affected: NFT (NFT Login).