NFT - Temporarily Unavailable
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted May 22, 2022 - 20:59 HKT
Update
We are continuing to investigate this issue.
Posted May 22, 2022 - 20:40 HKT
Investigating
Some users may temporarily be unable to access the NFT platform. The relevant teams are working urgently to resolve as soon as possible. Thank you for your patience.
Posted May 22, 2022 - 19:39 HKT
This incident affected: NFT (NFT Login, NFT Website, NFT Purchase, NFT Sale, NFT Withdraw, NFT Deposit).