Investigating connections with GBP fiat wallet Withdrawals

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 05:18 HKT

Update

We are continuing to investigate this issue.
Posted Aug 19, 2025 - 04:31 HKT

Investigating

- One of our GBP fiat wallet vendor “Clearbank” is currently having some issues processing withdrawals.
- Users can use our alternative GBP vendor “BCB” instead during this period for GBP withdraws
- For existing withdraw through Clearbank, it will be resumed once issue is resolved.
Posted Aug 19, 2025 - 04:25 HKT
This incident affected: Crypto.com App/Web Wallet (Fiat Wallets).