Email Notification Delays
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 14:31 HKT
Identified
We are aware of an intermittent issue with emails being delayed. We are working with our partners on this. Thank you for your patience.
Posted Oct 08, 2020 - 20:53 HKT
This incident affected: Crypto.com App (Notifications).