FIL Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Mar 20, 2021 - 09:35 HKT
Investigating
FIL deposits/withdrawals are delayed. We are currently investigating this issue.
Posted Mar 19, 2021 - 01:45 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).