App Slowness and Exchange Login Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 04:38 HKT
Investigating
We are currently investigating this issue
Posted Jan 08, 2021 - 02:39 HKT
This incident affected: Crypto.com App (Main Page) and Crypto.com Exchange (Web Server).