NFT Scheduled Maintenance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 22, 2022 - 11:57 HKT
Investigating
We are currently under system maintenance for the NFT platform from 10:00 HKT ( 02:00 UTC) on 22th Aug 2022. The maintenance is expected to take approximately 2 hours, but may vary depending on the circumstances on the day.

During this time, services on the platform will be temporarily suspended.
Posted Aug 22, 2022 - 10:04 HKT
This incident affected: NFT (NFT Login, NFT Website, NFT Purchase, NFT Sale, NFT Withdraw, NFT Deposit).