Europe & UK: Crypto.com Visa Cards (Transactions, Topup, Balance, History) - Scheduled Maintenance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted May 13, 2022 - 10:26 HKT
Investigating
We are currently performing scheduled system maintenance for Crypto.com Visa Cards - Europe & UK, as previously communicated.

Maintenance is expected to take approximately 2.5 hours but may vary depending on the circumstances on the day.

Europe & UK Cardholders will not be able to use their Crypto.com Visa Cards during the maintenance period. All features in the Crypto.com App Card section (EU & UK) will be suspended during maintenance. Updates to transaction history (EU & UK) may be delayed.


Rest assured that users' funds will remain safe, as always. Thank you for your support and understanding.
Posted May 13, 2022 - 07:55 HKT
This incident affected: Crypto.com App (Card and Staking).