ADA Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 15:11 HKT
Identified
ADA withdrawals are delayed. We've identified this issue and implementing a fix.
Posted Sep 10, 2021 - 09:59 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).