Crypto.com Visa Cards - System Maintenance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 19, 2022 - 15:08 HKT
Investigating
One of our 3rd party vendors has a planned maintenance for 30 minutes between 4:00AM and 4:30AM UTC on Saturday, 19 November, that may impact for a short period of time your Crypto.com Visa Cards top ups, purchases and ATM withdrawals. Please rest assured that your funds are safe and secure.
Posted Nov 19, 2022 - 11:59 HKT