Withdrawals Paused
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 21, 2020 - 16:47 HKT
Investigating
All withdrawals have been paused as we investigate an issue. Thank you for your patience
Posted Sep 21, 2020 - 00:29 HKT
This incident affected: Crypto.com App Wallet (Withdrawals).