AED,USD,SGD fiat wallet vendor "Standard Chartered" maintenance

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Nov 30, 2025 - 05:43 HKT

Monitoring

Our AED,USD,SGD fiat wallet vendor "Standard Chartered" it currently undergoing maintenance.

During this period, users relying on Standard Chartered will be unable to initiate FIAT AED,USD,SGD withdrawals.
Posted Nov 30, 2025 - 04:21 HKT