Monoova banking option unavailable for AUD deposits/withdraws

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Sep 24, 2026 - 19:31 HKT

Investigating

One of our AUD banking provider vendor "Monoova" is currently under going maintenance.

During this period, users will not be able to use Monoova for AUD fiat deposit/withdraw.

- Users can use our alternative AUD vendor "Assembly Payments" instead during this period.

- For existing deposit/withdraw through Monoova, it will be resumed once the maintenance is complete.
Posted Sep 24, 2026 - 19:16 HKT