ETH staking process delayed

Incident Report for Crypto.com

Update

The wait can be up to 70 days. For more information on latest ETH Validator queue backlog, please check here: https://www.validatorqueue.com/
Posted Mar 21, 2026 - 16:50 HKT

Identified

Please note ETH staking process is currently delayed due to current Ethereum Validator Queue size.
Posted Mar 21, 2026 - 16:49 HKT