Intermittent Issues for Android Users
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 18:43 HKT
Investigating
We have received several reports from Android app users of issues or slowness when loading the app.

We are currently investigating the issue and putting up this notice in case other users are affected.
Posted Jan 12, 2021 - 17:07 HKT