NEO Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 02, 2021 - 11:39 HKT
Monitoring
NEO withdrawals are delayed. We are currently monitoring this issue.
Posted Nov 01, 2021 - 21:40 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).