Crypto Deposits Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 10, 2021 - 23:57 HKT
Investigating
Crypto deposits are delayed. We are currently investigating this issue.
Posted Jan 10, 2021 - 21:27 HKT
This incident affected: Crypto.com Exchange (Deposits) and Crypto.com App Wallet (Deposits).