App Slowdowns
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Mar 25, 2021 - 23:05 HKT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2021 - 22:05 HKT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2021 - 22:02 HKT
Investigating
We are aware of users experiencing a slowdown of multiple app screens.

Our team is working on urgently resolving this. Thank you for your patience.
Posted Mar 25, 2021 - 21:54 HKT
This incident affected: Crypto.com App (Main Page, Card and Staking).