Crypto.com App Paused for Maintenance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 21, 2020 - 16:47 HKT
Investigating
We are currently investigating the issue
Posted Sep 21, 2020 - 00:40 HKT
This incident affected: Crypto.com App (Main Page, Track Coins, Notifications, Onboarding, Card and Staking) and Crypto.com App Wallet (Buy, Sell, Send, Withdrawals).