SMS Delivery Delays
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Apr 09, 2022 - 00:58 HKT
Monitoring
We are aware the issue with SMS not being received on Brazilian carriers
Posted Apr 05, 2022 - 01:18 HKT
This incident affected: Crypto.com App (Notifications).