Upstream DNS Issues
Incident Report for Crypto.com
Resolved
The upstream issues have been resolved. Thank you for your patience.
Posted Apr 30, 2020 - 07:20 HKT
Identified
We are experiencing some intermittent upstream DNS issues which will affect the Crypto.com website and Exchange.

Our teams are working very closely with our upstream providers to resolve this quickly.

We appreciate your patience, and apologize for the inconvenience.
Posted Apr 29, 2020 - 04:57 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (API Server - Spot/Margin, Web Server - Spot/Margin).