Intermittent Issue with placing UpDown and Strike options

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Nov 28, 2024 - 09:49 HKT

Investigating

We have identified an issue with placing UpDown and Strike options. Please bear with us whilst our teams are currently investigating this with the highest priority.
Posted Nov 28, 2024 - 05:44 HKT