Crypto.com Tax - Scheduled Maintenance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 15:48 HKT
Investigating
Please be informed that we are under system maintenance for Crypto.com Tax as previously communicated, starting from 14:00 PM HKT (06:00 UTC) on 29 June 2022. It is expected to take approximately two hours, but may vary depending on the circumstances on the day.
All features on the Crypto.com Tax will be suspended, and you will not be able to log in.
Posted Jun 29, 2022 - 14:05 HKT
This incident affected: TAX (Login, Website, CSV Import, API Import, Blockchain Import, Tax Report Generation).