SMS Delivery Delays
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 20:31 HKT
Investigating
We are aware of SMS delays/undelivered affecting customers from the Czech Republic, Kuwait, Saudi Arabia and Philippines.

The team is working with our partners to resolve this as soon as possible. Thank you for your patience.
Posted Dec 14, 2021 - 19:34 HKT
This incident affected: Crypto.com App (Notifications).