NFT Minting & Transfer Experiencing Delays

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Oct 06, 2021 - 16:04 HKT

Update

We are continuing to investigate this issue.
Posted Oct 01, 2021 - 19:07 HKT

Investigating

Some users are experiencing delays in the minting and transfers of their NFTs. Our team is investigating with urgency on this. Thank you for your patience.
Posted Oct 01, 2021 - 19:03 HKT
This incident affected: NFT (NFT Sale).