BNB Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 17, 2020 - 18:38 HKT
Investigating
BNB withdrawals are delayed. We are currently investigating this issue.
Posted Oct 17, 2020 - 15:29 HKT
This incident affected: Crypto.com Exchange (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).