A few cryptocurrency deposits/withdrawals delayed
Incident Report for Crypto.com
Update
We are continuing to monitor for any further issues.
Posted May 17, 2022 - 01:32 HKT
Monitoring
Arweave Network AR deposits/withdrawals are delayed.
We are currently monitoring these issues.
Posted May 13, 2022 - 10:59 HKT
This incident affects: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).