STX Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 12:17 HKT
Update
We are continuing to monitor for any further issues.
Posted Sep 16, 2021 - 23:46 HKT
Monitoring
STX withdrawals are delayed. We are currently monitoring this issue.
Posted Sep 04, 2021 - 11:58 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).