Intermittent email issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Dec 05, 2020 - 06:52 HKT
Update
We are continuing to investigate this issue.
Posted Dec 05, 2020 - 06:15 HKT
Investigating
Users have reported issues receiving emails. We are currently investigating the route cause for the problem and will provide timely reports on progress and resolution. Thank you for your patience.
Posted Dec 05, 2020 - 04:30 HKT
This incident affected: Crypto.com App (Notifications).