Cardano (ADA) Withdrawals Impacted
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 10:28 HKT
Investigating
Cardano (ADA) withdrawals are experiencing issues due to internal system error. We are working hard to fix it.
Posted Jun 22, 2020 - 01:13 HKT
This incident affected: Crypto.com Exchange (Withdrawals) and Crypto.com App Wallet (Withdrawals).