Card Top Ups Impacted
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 05, 2020 - 19:41 HKT
Identified
We are aware of an issue with card top ups, and are working with our partners to rectify this. Thank you for your patience
Posted Oct 05, 2020 - 19:04 HKT
This incident affected: Crypto.com App (Card and Staking).