NFT purchase and withdrawals temporarily unavailable
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 18:51 HKT
Identified
The team is aware of issues preventing customers to purchase NFT with Visa/ MasterCard; and further causing a delay in NFT withdrawals. Please rest assured our team is engaged with the problem and we are looking to resolve it as soon as possible.
Posted Oct 13, 2021 - 14:16 HKT
This incident affected: NFT (NFT Purchase, NFT Withdraw).