App slowness
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 22:10 HKT
Investigating
We are aware the app is experiencing slowness. The team is working on this as top priority.

Thank you for your patience, and we apologize for the inconvenience.
Posted Feb 01, 2021 - 21:53 HKT
This incident affected: Crypto.com App Wallet (Buy, Sell, Send, Withdrawals, Deposits, Fiat Wallets) and Crypto.com App (Main Page, Track Coins, Notifications, Onboarding, Card and Staking).