Tax - Login Portal Issue
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 09, 2021 - 14:05 HKT
Investigating
We are aware of the login issue with our login portal. As a result, some users may not be able to login and receive email one-time-password.

The team is working on resolving this as soon as possible. Thank you for your patience.
Posted Nov 08, 2021 - 14:27 HKT
This incident affected: TAX (Login).