All Withdrawals Paused
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 03, 2020 - 22:49 HKT
Identified
We are working to re-enable all withdrawals shortly. We appreciate your continued patience.
Posted Nov 03, 2020 - 22:38 HKT
Investigating
We are undergoing an unscheduled maintenance with withdrawals at the moment. Thank you for your patience
Posted Nov 03, 2020 - 21:59 HKT
This incident affected: Crypto.com App Wallet (Withdrawals) and Crypto.com Exchange (Spot/Derivatives) (Withdrawals).